Issue
When navigating to the History or Logs page for a Replication in the SKP, no data appears. You might see a loading icon but data never displays. Some users have also reported seeing an HTTP error code, such as 500.
Resolution
From the server hosting the Replicate Management Center, configure the logs to a limit of 10 files of 10 Mb each.
Replicate Product Help - Monitoring Text Log File Size
Cause
This issue is caused by the page being unable to process very large log file sizes.