Issue
When starting the Replicate client tool's Management Center the following error appears and it is not possible to work in the application.
System.ServiceModel.FaultException'1[DataReplication.Server.Metadata.Remoting.MetadataFault]:
Object reference not set to an instance of an object.
(Fault Detail is equal to DataReplication.Server.Metadata.Remoting.MetadataFault).
The application will close
Resolution
The simplest method to resolve this issue is to back up the metadata to an XML file and then immediately restore the metadata from that same XML file (Product Help). The restore process is able to correct various possible corruptions in the metadata.
If the issue remains after restoring the metadata, then our support team will need to assist you with correcting the metadata. Please attach your metadata XML file to a support request.
Cause
Note: This issue might have multiple specific causes, but our product teams have not yet found any means of reproducing it. If you identify a method that consistently causes the issue, please submit a request and let us know.
This issue is caused by corrupted metadata. The prevailing theory is that the corruption is caused by multiple users working in the Management Center simultaneously, all triggering updates to the metadata.
In general, the best practice to avoid this issue is to limit how many users have access to the Management Center. Furthermore, if any changes are made in the Management Center, users should be instructed to either close the application or run the "Refresh Metadata" operation ASAP. These actions serve to commit the metadata changes to the database.