These timeout errors may appear when upgrading to any SST (formerly DSP) version.
Problem 1
This error appears during the upgrade of the CTSConfig component.
The service was unable to evaluate the non-query statement.
Execution Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
The statement has been terminated.
Cause 1
This issue is caused by a large number of additional CTS Configurations on the Admin > CTS > Configuration page. The default volume of records in the CranSoft.dbo.CTSConfigObject table is less than 1000 but additional CTS Configurations can raise that volume to the tens of thousands.
Solution 1
- Run this query to back up and remove data in the CranSoft.dbo.CTSConfigObject table that is causing the timeout.
USE CranSoft
SELECT * INTO CTSConfigObject_bkp_support FROM CTSConfigObject
WHERE DataSourceID NOT IN (
'FEA97965-607D-44E9-954B-11AC2E53CAE6', 'C587B939-1558-4B8C-8CD1-1D691C898469',
'BF2E1962-95D8-4B7A-A7C8-240775D972B8', 'C454D012-BDFF-461F-B4AC-265DCCF01A9A',
'87EBC970-78FA-4C9B-927B-2ABCD3A15D1E', '07DC1191-63E8-4F83-BD75-64DD6638FDE1',
'5C362389-A5F4-4C83-8E15-9DE222551329', 'AA6EF286-B933-4C14-AB50-A00499219E2D',
'A0614870-CE11-478E-AC2D-A72DC5E31413', '67D300B5-ECE4-4537-8479-A9A1797D454A',
'F704C419-2A8F-4C92-AFD4-AD75EA7B9C93', '2FFA14CC-1E8A-4256-9415-C4E832CD72E7',
'A4098B88-314B-47FB-B89E-C700C076A0DA'
)
DELETE FROM CTSConfigObject
WHERE DataSourceID NOT IN (
'FEA97965-607D-44E9-954B-11AC2E53CAE6', 'C587B939-1558-4B8C-8CD1-1D691C898469',
'BF2E1962-95D8-4B7A-A7C8-240775D972B8', 'C454D012-BDFF-461F-B4AC-265DCCF01A9A',
'87EBC970-78FA-4C9B-927B-2ABCD3A15D1E', '07DC1191-63E8-4F83-BD75-64DD6638FDE1',
'5C362389-A5F4-4C83-8E15-9DE222551329', 'AA6EF286-B933-4C14-AB50-A00499219E2D',
'A0614870-CE11-478E-AC2D-A72DC5E31413', '67D300B5-ECE4-4537-8479-A9A1797D454A',
'F704C419-2A8F-4C92-AFD4-AD75EA7B9C93', '2FFA14CC-1E8A-4256-9415-C4E832CD72E7',
'A4098B88-314B-47FB-B89E-C700C076A0DA'
) - Resume the upgrade.
- After the upgrade is completed, run this query to restore the removed data in the CranSoft.dbo.CTSConfigObject table.
USE CranSoft
INSERT INTO CTSConfigObject
SELECT * FROM CTSConfigObject_bkp_support
Problem 2
When upgrading a DSP instance, an error is caused by the LogType table in Cransoft. The table causes a timeout during the upgrade process, even though the table contains few records.
The full text of the console error reads:
The service was unable to evaluate the non-query statement.
Timeout expired. The timeout period elapse prior to completion of the operation or the server is not responding.
The statement has been terminated.
Solution 2
Truncate the CranSoft.dbo.LogEntry table and then resume the upgrade. This should be done no matter how few records exist in the LogEntry table.