Version Applicability
All versions of DSP / ADM / ISA.
Issue
The following issues may be observed regarding the processing of the job queue:- Collect (& Assemble) refreshes are taking longer than expected to process.
- After clearing the queues and restarting the services and IIS, the queue continues to increase and never finishes processing.
Root Cause
This also occurs due to a known bug: no threads available to Automate Interfaces in the "General" Queue causing duplication of Automate jobs. ([DSP70-412] - Automate: "Interface (Initiator)" duplicates Jobs when Queue is full).
Resolution
- Navigate to Admin > Configuration > Service > Queues in the Navigation pane.
- Click Add.
- Enter Automate in the QUEUE NAME field.
- Set a times for the queue to start and stop in the START TIME and END TIME fields.
- Navigate to Automate > Interfaces in the Navigation pane.
- Click Edit for all of the Automate interfaces, click the QUEUE ID drop-down menu and select Automate.
Remove the duplicate Automate jobs from the queue:
- Navigate to Admin > Resources > Queues in the Navigation pane.
- Click the Clear Queue icon for the Automate QUEUE.
Add a new Service Provider and assign the Service Pages Queue to it, configuring it to go from 4 to 12 threads. Repeat these steps to increase the General Queue from 8 to 12 threads.
To add a service queue:
- Select Admin > Configuration > Service > Service Providers in the Navigation pane.
- Click the Queues icon for a service provider.
- Click Add.
- Enter a priority in the PRIORITY field.
NOTE: The priority sets the display order on the page. - Select Service Pages from the QUEUE ID list box.
- Enter 12 in the MAXIMUM THREADS field.
- NOTE: The Administrator can specify how many parallel processes can be
- actioned on the queue at any one time. The user must understand the underlying server architecture to set the number of queues based on the number of processor cores and threads available.
Next, clear the Service Page jobs that accumulated in the queue.
Finally, restart the DSP service.
If you are still experiencing issues with job queues processing slowly, please feel free to contact our support team at support.syniti.com.